登录后台

页面导航

本文编写于 1244 天前,最后修改于 1244 天前,其中某些信息可能已经过时。

POJ 2449

题目链接:

http://poj.org/problem?id=2449

Description

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story.

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission."

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)"

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister's help!

DETAILS: UDF's capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince' current place. M muddy directed sideways connect some of the stations. Remmarguts' path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate.
Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T.

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).
Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.

Sample Input

2 2
1 2 5
2 1 4
1 2 2

Sample Output

14

参考题解

POJ2449(dijkstra+A*)

代码(内存超限)

#include <cstdio>
#include <queue>
#include <vector>
#include <iostream>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    int to, val;
};
struct node1
{
    int pos, val;
    bool operator<(const node1 &a) const
    {
        return a.val < val;
    }
};
struct point
{
    int pos, g, h;
    bool operator<(const point &a) const
    {
        return a.g + a.h < g + h;
    }
};
priority_queue<node1> que;
priority_queue<point> que1;
vector<node> v[1050];
int dis[1050] = {0};
int cnt[1050] = {0};
void dijikastra(int start)
{
    dis[start] = 0;
    que.push({start, dis[start]});
    while (!que.empty())
    {
        node1 now = que.top();
        que.pop();
        for (int j = 0; j < v[now.pos].size(); j++)
        {
            node i = v[now.pos][j];
            if (dis[i.to] > now.val + i.val)
            {
                dis[i.to] = now.val + i.val;
                que.push({i.to, dis[i.to]});
            }
        }
    }
}
int A_stra(int start, int end, int k)
{
    if (start == end)
        k++;
    if (dis[start] == inf)
    {
        return -1;
    }
    que1.push({start, 0, dis[start]});
    while (!que1.empty())
    {
        point now = que1.top();
        que1.pop();
        cnt[now.pos]++;
        if (cnt[end] == k)
            return now.g + now.h;
        if (cnt[now.pos] > k)
            continue;
        for (int j = 0; j < v[now.pos].size(); j++)
        {
            node i = v[now.pos][j];
            que1.push({i.to, now.g + i.val, dis[i.to]});
        }
    }
    return -1;
}
bool cmp(node a, node b)
{
    return a.val < b.val;
}
int main()
{
    int n, m;
    scanf("%d%d", &n, &m);
    for (int i = 1; i <= n; i++)
        dis[i] = inf;
    int from, to, val;
    for (int i = 1; i <= m; i++)
    {
        scanf("%d%d%d", &from, &to, &val);
        v[from].push_back({to, val});
    }
    for (int i = 1; i <= n; i++)
        sort(v[i].begin(), v[i].end(), cmp);
    int start, end, k;
    scanf("%d%d%d", &start, &end, &k);
    dijikastra(end);
    printf("%d\n", A_stra(start, end, k));
}